Resolved
All services are within normal levels.
Monitoring
We have fixed the issue, and GET payments endpoint and payment list on Dashboard latency is no longer impacted. We continue to monitor it and will provide another update, shortly.
Investigating
We are experiencing issues with latency on GET payments endpoint and payment list on Dashboard. We will provide further details as it becomes available. Payment processing is not being impacted.