Resolved
All services are now within normal levels.
Monitoring
This issue does not affect merchant access. All merchants can continue to log in as normal. We will continue to monitor and provide updates.
Investigating
Some users may be experiencing issues signing in via Google SSO. Our team is actively investigating and will share updates as we learn more.