Resolved
All services are within normal levels.
Identified
Payment processing has been restored in production. Sandbox recovery is ongoing.
Identified
The downstream infrastructure provider is recovering and we are working to resolve the issue.
Investigating
We have been made aware by one of our downstream infrastructure providers that they are currently experiencing issues, and are working to have it resolved.