3DS - Mastercard Directory Server degradation
Resolved
Lasted for 18h

Mastercard has resolved the disruption to their Identity Check service as of T14:21:00 - 2023-06-12. 3DSecure services are no longer impacted.

Tue, Jun 13, 2023, 08:36 AM
11 months ago
Affected components

No components marked as affected

Updates

Resolved

Mastercard has resolved the disruption to their Identity Check service as of T14:21:00 - 2023-06-12. 3DSecure services are no longer impacted.

Tue, Jun 13, 2023, 08:36 AM
18h earlier...

Monitoring

We have identified that Mastercard are experiencing Service Disruption with their Directory Server (https://status.3dsecure.io/) which is impacting 3DS performance. We are monitoring and will provide updates as soon as they are available.

Mon, Jun 12, 2023, 01:40 PM