Pay.nl Outage
Resolved
Lasted for 2h

This incident has been resolved.

Tue, Nov 7, 2023, 01:21 PM
6 months ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Nov 7, 2023, 01:21 PM
2h earlier...

Identified

Pay.nl is having an outage with their API Service and Payment Processing. This may affect Primer customers using Pay.nl integrations. You can follow updates here: https://status.pay.nl/

Tue, Nov 7, 2023, 11:07 AM