Increased processing times for payments
Resolved
Lasted for 17h

Our 3rd party provider resolved the issue as of 12:00am - 19th January 2024. Payments are no longer impacted.

We are reviewing with our provider the root cause of this issue while working on remedial actions to affected merchants.

Fri, Jan 19, 2024, 09:57 AM
4 months ago
Affected components

No components marked as affected

Updates

Resolved

Our 3rd party provider resolved the issue as of 12:00am - 19th January 2024. Payments are no longer impacted.

We are reviewing with our provider the root cause of this issue while working on remedial actions to affected merchants.

Fri, Jan 19, 2024, 09:57 AM
11h earlier...

Monitoring

Our 3rd party cloud provider has fixed the issue on their side and we’re seeing performance return to normal levels. We will continue to monitor closely.

Thu, Jan 18, 2024, 10:41 PM
1h earlier...

Identified

Our engineering team has identified that the issue stems from one of our 3rd party cloud providers. This is causing intermittent issues where there is a latency with processing payments.

We are working with the provider so they can rectify this as soon as possible.

Thu, Jan 18, 2024, 09:33 PM
4h earlier...

Monitoring

Our engineering team has increased the capacity of the infrastructure to better handle the backlog of payments, this has reduced the latency in the processing of payments.

We will continue to monitor the performance to ensure the issue is completely resolved.

Thu, Jan 18, 2024, 04:55 PM
17m earlier...

Investigating

We have discovered an issue with the way our workflows are processing payments, this is causing an increase in the processing time.

Our engineering team is investigating the root cause of this incident.

Thu, Jan 18, 2024, 04:38 PM