Degraded performance for Observability and Monitors
Resolved
Degraded performance

The performance issue that was impacting the Observability and Monitors services has been fully resolved, now. Services are back to normal levels. We apologise for the inconvenience that this issue may have caused, but rest assured that its speedy resolution remained a priority and that we did our utmost to have it resolved quickly. Thank you for your understanding.

Wed, Jan 8, 2025, 05:16 PM
3 weeks ago
Affected components
Updates

Resolved

The performance issue that was impacting the Observability and Monitors services has been fully resolved, now. Services are back to normal levels. We apologise for the inconvenience that this issue may have caused, but rest assured that its speedy resolution remained a priority and that we did our utmost to have it resolved quickly. Thank you for your understanding.

Wed, Jan 8, 2025, 05:16 PM
22h earlier...

Identified

The sandbox database maintenance that was ongoing has completed successfully and we're happy to announce that performance has resumed to typical values. Please note that the performance issue impacting Observability in production is still ongoing, with degraded performance, but that it should get resolved after the emergency database maintenance scheduled for tomorrow at 4am-8am UTC as announced already. Thank you for your patience.

Tue, Jan 7, 2025, 06:43 PM
5h earlier...

Identified

As part of the actions needed to fix this issue, we're required to perform immediate database maintenance, which is currently underway, and this causes the Observability service to be unavailable during the maintenance period (sandbox only for now), expected to last few hours. We will provide a more precise maintenance period duration as soon as possible. Please note that this issue does not impact payment processing in any way. Thank you for patience and continued support.

Tue, Jan 7, 2025, 01:16 PM
4d earlier...

Identified

We are currently experiencing degraded performance in our Observability and Monitors features. Our team is actively investigating the issue and working to resolve it as quickly as possible. We will provide another update as soon as more information becomes available. Thank you for your patience and understanding.

Fri, Jan 3, 2025, 01:04 PM