Payment timeline in Sandbox may not load
Resolved
Degraded performance

Due to a release done today at 15:04 UTC, payment processing in sandbox experienced degraded performance, which impacted the storing of all the payment details needed for the correct loading and displaying of payment information in the payment timeline. The payment details cannot be recovered and the timeline will not load correctly, for the impacted payments. The underlying issue has since been resolved, at 16:42 UTC, and payments in sandbox since that time are correctly processed, and its details are displayed in the timeline, correctly. We apologise for the inconvenience caused.

Fri, Mar 28, 2025, 05:49 PM
2d ago
Affected components
Primer Sandbox
Updates

Resolved

Due to a release done today at 15:04 UTC, payment processing in sandbox experienced degraded performance, which impacted the storing of all the payment details needed for the correct loading and displaying of payment information in the payment timeline. The payment details cannot be recovered and the timeline will not load correctly, for the impacted payments. The underlying issue has since been resolved, at 16:42 UTC, and payments in sandbox since that time are correctly processed, and its details are displayed in the timeline, correctly. We apologise for the inconvenience caused.

Fri, Mar 28, 2025, 05:49 PM
28m earlier...

Monitoring

We have identified the issue that is causing the payment timeline page to not show details for some payments, in sandbox, and issued a fix.

Fri, Mar 28, 2025, 05:21 PM
16m earlier...

Identified

We have identified that payment processing in sandbox, only, experienced degraded performance between 15:04 and 16:42 UTC and that during that period, for some payments, the payment timeline is not loading and showing an error. Payment processing in sandbox has since been restored, and we're continuing with the investigation regarding the payment timeline errors.

Fri, Mar 28, 2025, 05:05 PM

Investigating

We're currently investigating an issue where the payment timeline details in sandbox are not being displayed. We believe that payment processing in sandbox may also have been impacted.

Fri, Mar 28, 2025, 04:56 PM