Degraded performance for Observability and Monitors
Resolved·Degraded performance

We have monitored it for an extended period of time and can confirm that all service levels are back to normal. Thank you for your patience.

Tue, Apr 1, 2025, 03:17 PM
(3 weeks ago)
·
Affected components
Updates

Resolved

We have monitored it for an extended period of time and can confirm that all service levels are back to normal. Thank you for your patience.

Tue, Apr 1, 2025, 03:17 PM

Monitoring

The performance issue that was impacting the Observability and Monitors services has been resolved, and we're observing all service levels going back to normal. Payment details should be already up to date, in the Dashboard.

Tue, Apr 1, 2025, 02:29 PM(47 minutes earlier)

Identified

We are currently experiencing degraded performance in our Observability and Monitors features. Additionally, the data displayed in these features is currently stale. Our team is actively investigating the issue and working to resolve it as quickly as possible. We will provide another update as soon as more information becomes available. Thank you for your patience and understanding. Please note this is not impacting payment processing and settlement.

Tue, Apr 1, 2025, 01:42 PM(47 minutes earlier)