Payments failure between 13:00-13:02 UTC+1
Resolved·Full outage

Our services are operating normally. We're conducting a thorough investigation on the causes of the short interruptions of service experienced on Friday, and will be applying preemptive and corrective measures to avoid it from happening again. Thanks for your patience. Please contact our Support team via the Support Portal, in case you have any questions.

Mon, Apr 7, 2025, 11:10 AM
(2 weeks ago)
·
Affected components
Updates

Resolved

Our services are operating normally. We're conducting a thorough investigation on the causes of the short interruptions of service experienced on Friday, and will be applying preemptive and corrective measures to avoid it from happening again. Thanks for your patience. Please contact our Support team via the Support Portal, in case you have any questions.

Mon, Apr 7, 2025, 11:10 AM

Monitoring

We remain actively monitoring the situation.

Since our last update, we can confirm that all services are fully operational, within normal levels, and payment processing is not being impacted.

Sat, Apr 5, 2025, 04:18 PM(1 day earlier)

Monitoring

We experienced a drop in service levels lasting few minutes between 21:26-21:28 and 21:33-21:34 UTC+1 which impacted payment processing. Services have since recovered and we remain actively monitoring and performing fixes to address the issue. We will keep providing details, as we progress. Thank you for your cooperation.

Fri, Apr 4, 2025, 09:17 PM(19 hours earlier)

Resolved

The incident has been resolved, and no further impact has been seen since 13:36 UTC+1, as previously informed. Rest assured that we remain monitoring all our service levels and will inform you of any changes. We will provide additional information on this incident, shortly.

Fri, Apr 4, 2025, 08:22 PM(54 minutes earlier)

Monitoring

Payment processing service levels have fully recovered since 13:36 UTC+1. We are monitoring it very closely and will provide details on what has caused the issue, shortly. Thank you for your patience.

Fri, Apr 4, 2025, 01:19 PM(7 hours earlier)

Investigating

We believe that the degradation in service levels is being caused by a sudden increase of traffic, for which our infrastructure has been scaling up accordingly. We're still investigating the nature of this sudden increase of traffic. Thank you for your patience as we investigate this issue.

Fri, Apr 4, 2025, 01:05 PM(13 minutes earlier)

Investigating

We believe to be experiencing degraded payment processing performance once again. We're investigating.

Fri, Apr 4, 2025, 12:31 PM(33 minutes earlier)

Monitoring

Payment processing service levels have fully recovered since 13:08 UTC+1. We are monitoring it and will provide details on what caused the issue, shortly. Thank you for your patience.

Fri, Apr 4, 2025, 12:26 PM

Monitoring

Between 13:02 and 13:08 UTC+1 payment processing experienced degraded performance.

Fri, Apr 4, 2025, 12:24 PM

Monitoring

We are monitoring the payment service.

Fri, Apr 4, 2025, 12:08 PM(16 minutes earlier)

Investigating

We believe to have experienced a full outage between 13:00-13:02 UTC+1 impacting all payment processing. Service is now recovering and we're investigating it.

Fri, Apr 4, 2025, 12:00 PM