Increase in latency & payment errors
Resolved·Partial outage

All services are operating at normal levels.

Wed, Apr 9, 2025, 08:52 AM
(2 weeks ago)
·
Affected components
Updates

Resolved

All services are operating at normal levels.

Wed, Apr 9, 2025, 08:52 AM

Monitoring

As informed previously, payment processing was impacted for a total period of 2.5 minutes between 18:43 and 18:49 UTC+1. Apart from that period, payment processing services remained fully operational. Our focus remains in maintaining the service levels.

We continue to monitor the services and will provide further details frequently.

Tue, Apr 8, 2025, 07:26 PM(13 hours earlier)

Monitoring

Services levels have recovered and we're monitoring it very closely.

Tue, Apr 8, 2025, 06:42 PM(43 minutes earlier)

Investigating

We’re currently experiencing issues with payment processing, including increased latency and a higher rate of payment response errors. Our team is actively investigating the root cause and will provide updates as soon as more information becomes available. We appreciate your patience and understanding.

Tue, Apr 8, 2025, 06:08 PM(34 minutes earlier)