CyberSource Degraded Performance
Resolved·Degraded performance

The issue that was impacting CyberSource has been fully resolved, and our service levels are back to normal.

Fri, May 9, 2025, 04:01 PM
(1 week ago)
·
Affected components
Third-Party partners and providers
Updates

Resolved

The issue that was impacting CyberSource has been fully resolved, and our service levels are back to normal.

Fri, May 9, 2025, 04:01 PM

Monitoring

The CyberSource team has implemented a fix, and it's currently being monitored. We are now currently seeing transactions being processed correctly. We will continue to monitor this and will provide an update if needed.

Fri, May 9, 2025, 02:15 PM(1 hour earlier)

Monitoring

Cybersource is currently experiencing a service disruption that is impacting HSBC transaction processing. Their team is actively investigating the issue and working to implement a resolution. You can follow updates on their status page: https://status.cybersource.com. All other transactions are processing as normal. If you have any questions, please contact our support team.

Fri, May 9, 2025, 09:04 AM(5 hours earlier)