Payment processing impacted
Resolved·Degraded performance

After monitoring the service levels for an extended period of time, we have not observed any further issues and are considering it to be resolved.

Sun, Jun 29, 2025, 08:49 PM
(1 month ago)
·
Affected components
Updates

Resolved

After monitoring the service levels for an extended period of time, we have not observed any further issues and are considering it to be resolved.

Sun, Jun 29, 2025, 08:49 PM

Monitoring

Payment processing performance has returned to normal levels since 20 minutes ago and we have been monitoring it very closely to guarantee that it remains under normal levels. We will provide further details on this issue, soon. For now, the degraded service seems to be due to a sudden and very high volume of requests reaching our services, and the time needed to have all services scaled up accordingly. Thank you for your patience and understanding, and apologies for the inconvenience caused.

Sun, Jun 29, 2025, 08:02 PM(47 minutes earlier)

Investigating

Payment processing is currently impacted and experiencing degraded performance. We are investigating it.

Sun, Jun 29, 2025, 07:08 PM(53 minutes earlier)