Resolved
We have monitored the situation for an extended period of time and can confirm that all service levels are back to normal. Thank you for your patience.
Monitoring
We’ve deployed a fix for the issue impacting network tokenized (NT) card payments via Stripe. We'll continue to monitor but payments are now processing successfully, and decline rates have returned to normal. Thank you for your patience while we looked into and resolved this.
Investigating
We are currently investigating an issue where all network tokenized (NT) card payments processed via Stripe were declined with the error "Your card number is incorrect", which started today at 16:00 UTC. We are currently investigating and will provide another update as soon as more information becomes available.