Resolved
Delivery times have returned to normal and we’ve not seen any further issues since mitigation. We’ll continue monitoring, but this incident is now considered resolved. We apologize for any inconvenience.
Monitoring
We observed elevated webhook latency between 16:02 and 17:05 UTC. The issue has since been mitigated and delivery times have returned to normal. We’ll continue to monitor to ensure stability.