Fiserv Degraded Performance
Resolved·Degraded performance

All transactions processed via Fiserv are now completing successfully, and we are no longer observing any issues. We will continue to monitor the situation closely, but this incident is now considered resolved.

If you notice any irregularities, please do not hesitate to reach out to our Support Team for assistance.

We apologize for any inconvenience this may have caused and appreciate your understanding.

Wed, Jul 23, 2025, 05:25 AM
(1 week ago)
·
Affected components
Third-Party partners and providers
Updates

Resolved

All transactions processed via Fiserv are now completing successfully, and we are no longer observing any issues. We will continue to monitor the situation closely, but this incident is now considered resolved.

If you notice any irregularities, please do not hesitate to reach out to our Support Team for assistance.

We apologize for any inconvenience this may have caused and appreciate your understanding.

Wed, Jul 23, 2025, 05:25 AM

Monitoring

We’re seeing that transactions with Fiserv are now processing successfully again and we’re continuing to monitor the situation closely.

If you notice any irregularities or ongoing issues, please don’t hesitate to reach out to our support team.

We appreciate your patience and understanding.

Wed, Jul 23, 2025, 04:15 AM(1 hour earlier)

Identified

We’re currently observing an issue where transactions processed via Fiserv are timing out. Our investigations has determined that the issue originates on Fiserv's side.

We are actively working with their team to help them resolve this as quickly as possible.

All other processors and payment methods remain fully operational.

We’ll continue to provide updates here as we learn more.

Thank you for your patience and understanding.

Wed, Jul 23, 2025, 01:36 AM(2 hours earlier)