All transactions processed via PayPal are now completing successfully, and we are no longer observing any issues. While we will continue to monitor closely, this incident is now considered resolved. If you experience any further issues or notice any irregularities, please contact our Support Team for assistance. We sincerely apologise for any inconvenience caused and thank you for your patience and understanding.
Resolved
All transactions processed via PayPal are now completing successfully, and we are no longer observing any issues. While we will continue to monitor closely, this incident is now considered resolved. If you experience any further issues or notice any irregularities, please contact our Support Team for assistance. We sincerely apologise for any inconvenience caused and thank you for your patience and understanding.
Identified
We are currently observing an issue causing timeouts for transactions processed via PayPal. Our investigation has determined that the issue originates on PayPal’s side. All other processors and payment methods remain fully operational. We will continue to share updates here as more information becomes available. Thank you for your patience and understanding.