Resolved
We have fixed the issue, The Observability Dashboard is now updated and no longer experience stale data. Thank you for your patience and understanding.
Identified
We have identified the cause of the issue and are currently rolling out a fix.
Investigating
We’re currently experiencing issues with stale data in the Observability Dashboard. We will provide further details as it becomes available.