Apple Pay Timeouts
Resolved·Degraded performance

All services are within normal levels.

Tue, Jan 6, 2026, 03:58 PM
(6 days ago)
·
Affected components
Third-Party partners and providers
Updates

Resolved

All services are within normal levels.

Tue, Jan 6, 2026, 03:58 PM

Monitoring

Timeouts are no longer occurring for Apple Pay payments, and the service is no longer impacted. We continue to monitor the situation closely and will provide a further update shortly.

Tue, Jan 6, 2026, 03:31 PM(27 minutes earlier)

Investigating

We are currently experiencing issues with Apple Pay transactions. We will provide further details as it becomes available.

Tue, Jan 6, 2026, 03:15 PM(15 minutes earlier)