No components marked as affected
Resolved
All services are within normal levels.
Monitoring
We identified an issue that caused some PayPal payments to fail between 12:06 UTC and 12:58 UTC. The issue has been resolved, and we are currently monitoring the results.