Resolved
The issue causing stale data in the Dashboard and Monitors within the Sandbox environment has been resolved, and data is now updating as expected.
All services are within normal levels.
Investigating
We are currently experiencing issues with stale data in the Dashboard and Monitors in the Sandbox environment.
Our team is investigating the issue. We will provide further updates as more information becomes available.