Resolved
All services are within normal levels.
Monitoring
We have fixed the issue, and the Dashboard Payment Timeline for 3DS is no longer impacted. We continue to monitor it and will provide another update, shortly.
Identified
We have identified the cause of the issue and are working to have it fixed.
Investigating
We are experiencing issues with the Dashboard Payment Timeline when accessing 3DS information. Payment processing is not impacted.