Identified
The PayPal team has identified the cause of the issue and are working to have it fixed.
Investigating
We have been made aware by PayPal that they are currently experiencing issues affecting the PayPal SDK on Safari 26.5.2. As a result, our merchant checkouts configured with the PayPal payment method may crash or reload.
Merchants seeing issues with their checkout on Safari 26.5.2 may wish to temporarily disable PayPal as a checkout option until PayPal resolves the issue.
We will post an update once PayPal confirms a fix is live.