Resolved
All services are within normal levels.
Monitoring
We have identified the cause as an issue on Mastercard's end affecting payments.
Aside from this, Primer's platform continues to operate normally. Transaction volumes have stabilized, and we will continue to monitor closely.
We will provide a further update once the issue is fully resolved.
Investigating
We are experiencing issues with payment processing. We will provide further details as it becomes available.