3rd Party Service degradation in APAC
Incident Report for Primer
Resolved
This incident has been resolved. Downstream network provider (Cloudflare) has resolved the degradation in the APAC region. Payment request and checkout latency has been restored to normal values.
Posted May 31, 2023 - 10:05 UTC
Monitoring
We are currently experiencing downgraded performance in the APAC region due to a degradation of a downstream network provider (Cloudflare).

This has increased payment request and checkout latency. We are currently monitoring services impacted and are coordinating to identify possible mitigation measures.
Posted May 31, 2023 - 09:08 UTC
This incident affected: Primer Checkout.